Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/properties/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-04 22:49:27 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-04 22:49:27 (GMT)
commit8f535d303b8985db357abc54cb4d3fe1ff7e84bd (patch)
tree37d460e590ab9708c9d98a98986aa8d730746094 /properties/Makefile.am
parent690f1487f47c73f7785f0afcee73ea088144437d (diff)
Implement nautilus plugin for properties. Works only for pdf atm, I need
2005-07-05 Marco Pesenti Gritti <mpg@redhat.com> * configure.ac: * properties/Makefile.am: * properties/ev-properties-view.c: (ev_properties_view_register_type): * properties/ev-properties-view.h: * properties/ev-properties-main.h: Implement nautilus plugin for properties. Works only for pdf atm, I need to rework the document types stuff to get this to work for all backends...
Diffstat (limited to 'properties/Makefile.am')
-rw-r--r--properties/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/properties/Makefile.am b/properties/Makefile.am
index bac8f35..597fb5a 100644
--- a/properties/Makefile.am
+++ b/properties/Makefile.am
@@ -2,8 +2,11 @@ NULL=
INCLUDES= \
-DDATADIR=\"$(pkgdatadir)\" \
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-I$(top_srcdir)/backend \
- $(SHELL_CFLAGS) \
+ -I$(top_srcdir)/pdf \
+ $(PROPERTIES_CFLAGS) \
+ $(NAUTILUS_CFLAGS) \
$(EVINCE_DISABLE_DEPRECATED) \
$(NULL)
@@ -13,3 +16,23 @@ libevproperties_la_SOURCES= \
ev-properties-view.c \
ev-properties-view.h \
$(NULL)
+
+if HAVE_NAUTILUS
+EVINCE_PROPERTIES_PAGE = libevince-properties-page.la
+else
+EVINCE_PROPERTIES_PAGE =
+endif
+
+nautilus_LTLIBRARIES = $(EVINCE_PROPERTIES_PAGE)
+
+nautilusdir = $(libdir)/nautilus/extensions-1.0/
+libevince_properties_page_la_CFLAGS = -I$(top_srcdir)
+libevince_properties_page_la_SOURCES = \
+ ev-properties-main.c
+
+libevince_properties_page_la_LIBADD = \
+ $(PROPERTIES_LIBS) \
+ libevproperties.la \
+ $(top_builddir)/pdf/libpdfdocument.la \
+ $(top_builddir)/backend/libevbackend.la \
+ $(top_builddir)/lib/libev.la