Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/properties/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2009-06-04 18:03:54 (GMT)
committer Christian Persch <chpe@gnome.org>2009-06-11 21:38:07 (GMT)
commitbdca80a8cd31e0b00d8942ca0000f1fa46311a28 (patch)
treed46c5665296d4fd4d69dea24980afd81bc446f9c /properties/Makefile.am
parente2796d0d1a833e63c9495193c9241bd718f68082 (diff)
Don't use automagic dependencies
Default to enable, and require explicit disabling. Default to disabled on hildon for the nautilus extension, the thumbnailer and the previewer.
Diffstat (limited to 'properties/Makefile.am')
-rw-r--r--properties/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/properties/Makefile.am b/properties/Makefile.am
index 33d831e..0d2bf0e 100644
--- a/properties/Makefile.am
+++ b/properties/Makefile.am
@@ -14,15 +14,10 @@ libevproperties_la_SOURCES= \
ev-properties-view.c \
ev-properties-view.h
-if HAVE_NAUTILUS
-EVINCE_PROPERTIES_PAGE = libevince-properties-page.la
-else
-EVINCE_PROPERTIES_PAGE =
-endif
+if ENABLE_NAUTILUS
-nautilus_LTLIBRARIES = $(EVINCE_PROPERTIES_PAGE)
+nautilusextension_LTLIBRARIES = libevince-properties-page.la
-nautilusdir=$(NAUTILUS_EXTENSION_DIR)
libevince_properties_page_la_CFLAGS = -I$(top_srcdir)
libevince_properties_page_la_SOURCES = \
ev-properties-main.c
@@ -34,3 +29,5 @@ libevince_properties_page_la_LIBADD = \
$(NAUTILUS_LIBS)
libevince_properties_page_la_LDFLAGS = -module -avoid-version -no-undefined
+
+endif # ENABLE_NAUTILUS