Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2005-07-06 23:05:39 (GMT)
committer Marco Pesenti Gritti <marco@src.gnome.org>2005-07-06 23:05:39 (GMT)
commit02383ed04e6a5c215d6d3d4b961bc73b58a23b37 (patch)
tree086f2170e92faa6e5e6618f0a847655b00b94bce /shell/Makefile.am
parent6a456fd7b243b73177b1f9ddf9eddc315295b11a (diff)
This should solve the circular dep without requiring dir reorg!
2005-07-07 Marco Pesenti Gritti <mpg@redhat.com> * Makefile.am: * backend/Makefile.am: * properties/Makefile.am: * shell/Makefile.am: * thumbnailer/Makefile.am: This should solve the circular dep without requiring dir reorg! * shell/ev-window.c: (setup_view_from_metadata): Never restore window size/position when the window is already visible.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am30
1 files changed, 1 insertions, 29 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 24e3ab6..80b6ea5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -20,34 +20,6 @@ INCLUDES += $(DBUS_CFLAGS)
endif
bin_PROGRAMS=evince
-noinst_LTLIBRARIES = libevbackendfactory.la
-
-libevbackendfactory_la_SOURCES =
-
-libevbackendfactory_la_LIBADD = \
- $(top_builddir)/pdf/libpdfdocument.la \
- $(top_builddir)/pixbuf/libpixbufdocument.la \
- $(top_builddir)/ps/libgtkgs.la \
- $(top_builddir)/backend/libevbackend.la \
- $(NULL)
-
-if ENABLE_DJVU
-libevbackendfactory_la_LIBADD += \
- $(top_builddir)/djvu/libgtkdjvu.la \
- $(NULL)
-endif
-
-if ENABLE_TIFF
-libevbackendfactory_la_LIBADD += \
- $(top_builddir)/tiff/libtiffdocument.la \
- $(NULL)
-endif
-
-if ENABLE_DVI
-libevbackendfactory_la_LIBADD += \
- $(top_builddir)/dvi/libgtkdvi.la \
- $(NULL)
-endif
evince_SOURCES= \
dummy.cc \
@@ -116,8 +88,8 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
$(top_builddir)/properties/libevproperties.la \
$(top_builddir)/lib/libev.la \
+ $(top_builddir)/backend/libevbackend.la \
-ltiff -lz \
- libevbackendfactory.la \
$(NULL)
if ENABLE_DBUS