Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2006-08-05 10:40:56 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2006-08-05 10:40:56 (GMT)
commit63718064505c640af952c6e180b75235a1de5f14 (patch)
tree213f0d030710ece03ee26b98f878a56642382877 /shell/Makefile.am
parente47828bd9933f9a44cdfb009fdfcddfcec2748dd (diff)
Use GtkRecent instead of EggRecent when it's available. Fixes bug #349273
2006-08-05 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/Makefile.am: * data/evince-ui.xml: * shell/Makefile.am: * shell/ev-application.[ch]: * shell/ev-window.c: Use GtkRecent instead of EggRecent when it's available. Fixes bug #349273
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 4a6c5de..6c1cdcf 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -2,7 +2,6 @@ INCLUDES= \
-DDATADIR=\"$(pkgdatadir)\" \
-DGNOMEDATADIR=\"$(datadir)\" \
-I$(top_srcdir)/lib \
- -I$(top_srcdir)/cut-n-paste/recent-files/ \
-I$(top_srcdir)/cut-n-paste/zoom-control/ \
-I$(top_srcdir)/cut-n-paste/toolbar-editor/ \
-I$(top_srcdir)/backend \
@@ -15,6 +14,12 @@ INCLUDES= \
$(GNOME_PRINT_CFLAGS) \
$(GTK_PRINT_CFLAGS)
+if HAVE_GTK_RECENT
+INCLUDES +=
+else
+INCLUDES += -I$(top_srcdir)/cut-n-paste/recent-files/
+endif
+
bin_PROGRAMS=evince
evince_SOURCES= \
@@ -77,7 +82,6 @@ endif
evince_LDADD= \
- $(top_builddir)/cut-n-paste/recent-files/librecent.la \
$(top_builddir)/cut-n-paste/zoom-control/libephyzoom.la \
$(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
$(top_builddir)/properties/libevproperties.la \
@@ -85,6 +89,12 @@ evince_LDADD= \
$(SHELL_LIBS) \
$(GNOME_PRINT_LIBS)
+if HAVE_GTK_RECENT
+evince_LDADD +=
+else
+evince_LDADD += $(top_builddir)/cut-n-paste/recent-files/librecent.la
+endif
+
if ENABLE_DJVU
evince_LDADD += $(DJVU_LIBS)
endif