Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2008-06-24 18:15:12 (GMT)
committer Bastien Nocera <hadess@src.gnome.org>2008-06-24 18:15:12 (GMT)
commit7042909ab901b54e952410572b3d724e49094158 (patch)
tree0e0ec62510a1d2bef370d2b0d2f8e0ec1beebb04 /shell/Makefile.am
parent160bb033c06d78193c51d6cd1a671835c037c869 (diff)
When building with D-Bus support, listen for multimedia key events from
2008-06-24 Bastien Nocera <hadess@hadess.net> * shell/Makefile.am: * shell/ev-application.c (ev_application_init), (ev_application_get_media_keys): * shell/ev-application.h: * shell/ev-marshal.list: * shell/ev-media-player-keys.c (ev_media_player_keys_class_init), (proxy_destroy), (on_media_player_key_pressed), (ev_media_player_keys_init), (ev_media_player_keys_focused), (ev_media_player_keys_finalize), (ev_media_player_keys_new): * shell/ev-media-player-keys.h: * shell/ev-window.c (ev_window_go_previous_page), (ev_window_go_next_page), (ev_window_go_first_page), (ev_window_go_last_page), (ev_window_start_presentation), (ev_window_dispose), (view_actions_focus_in_cb): * shell/ev-window.h: When building with D-Bus support, listen for multimedia key events from gnome-settings-daemon. This allows to go to the next/previous/first/last pages using, respectively, Next/Previous/Rewing/Fast Forward. The Play button is used to start a presentation. Fixes bug #539971. svn path=/trunk/; revision=3059
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 824cf3f..3d85771 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -16,6 +16,13 @@ INCLUDES= \
bin_PROGRAMS=evince
+EV_MEDIA_PLAYER_KEYS_SOURCES = ev-media-player-keys.c ev-media-player-keys.h
+if ENABLE_DBUS
+DBUS_SOURCES = $(EV_MEDIA_PLAYER_KEYS_SOURCES)
+else
+DBUS_SOURCES = $(null)
+endif
+
evince_SOURCES= \
eggfindbar.c \
eggfindbar.h \
@@ -31,6 +38,7 @@ evince_SOURCES= \
ev-history.h \
ev-marshal.c \
ev-marshal.h \
+ $(DBUS_SOURCES) \
ev-message-area.c \
ev-message-area.h \
ev-metadata-manager.c \
@@ -105,7 +113,8 @@ BUILT_SOURCES += ev-application-service.h
endif
EXTRA_DIST = ev-marshal.list \
- ev-application-service.xml
+ ev-application-service.xml \
+ $(EV_MEDIA_PLAYER_KEYS_SOURCES)
ev-marshal.h: $(srcdir)/ev-marshal.list