Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2004-12-22 00:44:41 (GMT)
committer Owen Taylor <otaylor@src.gnome.org>2004-12-22 00:44:41 (GMT)
commita4cf673a3347ec011ebc90b22b6541bae0b9f6b4 (patch)
treec083238873e7fd943411e0bb2e1a761adf716783 /shell/Makefile.am
parentd6198ac2024d229d47b631648fe8352ffb4d3e80 (diff)
Switch from .a to libtool convenience libraries.
Tue Dec 21 19:28:55 2004 Owen Taylor <otaylor@redhat.com> * pdf/{goo,fofi,splash,xpdf}/Makefile.am: Switch from .a to libtool convenience libraries. * shell/ev-window.c (ev_window_open): Hard code loading a PDF document. * backend/ev-document.h: Add a boolean return to load(), fix GError * to GError **. * pdf/xpdf/pdf-document.[ch] Makefile.am: Add a stub object for a PDF backend EvDocument.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 7179a7d..891eadb 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -3,6 +3,8 @@ NULL=
INCLUDES= \
-DDATADIR=\"$(pkgdatadir)\" \
-I$(top_srcdir)/lib \
+ -I$(top_srcdir)/backend \
+ -I$(top_srcdir)/pdf/xpdf \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
$(SHELL_CFLAGS) \
$(EVINCE_DISABLE_DEPRECATED) \
@@ -22,6 +24,8 @@ evince_SOURCES= \
main.c \
$(NULL)
-evince_LDADD= \
- $(SHELL_LIBS) \
+evince_LDADD= \
+ $(SHELL_LIBS) \
+ $(top_builddir)/backend/libevbackend.la \
+ $(top_builddir)/pdf/xpdf/libpdfdocument.la \
$(NULL)