Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-03-13 20:35:57 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-03-13 20:35:57 (GMT)
commita61c4406e2cd4dc8f2d3a981e73dc09ae21e6ece (patch)
tree2a159577b6981e3e5d1b7b64c9a35a06dee5af5c /shell/Makefile.am
parent43532ba918c19ae764c0d024618bae67cea077d8 (diff)
Allow build from different dir
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 26b195e..c8703c0 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -95,12 +95,12 @@ EXTRA_DIST = ev-marshal.list \
ev-application-service.xml
-ev-marshal.h: ev-marshal.list
- glib-genmarshal --prefix=ev_marshal ev-marshal.list --header > ev-marshal.h
+ev-marshal.h: $(srcdir)/ev-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --header > ev-marshal.h
-ev-marshal.c: ev-marshal.list
+ev-marshal.c: $(srcdir)/ev-marshal.list
echo '#include "ev-marshal.h"' > ev-marshal.c
- glib-genmarshal --prefix=ev_marshal ev-marshal.list --body >> ev-marshal.c
+ $(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --body >> ev-marshal.c
DISTCLEANFILES= \
ev-application-service.h