Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-01-25 15:08:57 (GMT)
committer Christian Persch <chpe@src.gnome.org>2009-01-25 15:08:57 (GMT)
commit4912987303aefef0d02a45726b75e5fdae043982 (patch)
tree3856f1dc17d3c927436672171532942b997dfe2b /shell/Makefile.am
parentb2c387604ca233c9c70a0595a24d381ddfafd1d4 (diff)
Renamed from evince-backend.pc.in. Renamed library to libevdocument.la.
* configure.ac: * evince-document.pc.in: Renamed from evince-backend.pc.in. * libdocument/Makefile.am: Renamed library to libevdocument.la. * libview/Makefile.am: * shell/Makefile.am: * backend/*/Makefile.am: Adapt to changed library name. * libdocument/Makefile.am: * libview/Makefile.am: Change the installed headers path to match the directory names in SVN. * evince-document.h: * evince-view.h: Add single headers. Bug #568227. * libdocument/*.h: * libview/*.h: Add single headers guards. * libview/Makefile.am: * libdocument/Makefile.am: * backend/*/Makefile.am: * help/reference/Makefile.am: Define EVINCE_COMPILATION, so we can still include individual headers. * properties/Makefile.am: * properties/ev-properties-main.c: * properties/ev-properties-view.h: * thumbnailer/Makefile.am: * thumbnailer/evince-thumbnailer.c: Include only evince-document.h. * libdocument/Makefile.am: * libview/Makefile.am: Generate type builtins from all installed headers. * libdocument/ev-link-action.[ch]: * libdocument/ev-link-dest.[ch]: * libdocument/ev-transition-effect.[ch]: * libview/ev-view.[ch]: Remove handcoded type builtins. * libdocument/Makefile.am: * evince-document.h: Add ev-document-factory.h to the public headers. svn path=/trunk/; revision=3381
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index ab09ef9..4230dbb 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,6 +1,8 @@
INCLUDES= \
-DDATADIR=\"$(pkgdatadir)\" \
-DGNOMEDATADIR=\"$(datadir)\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
-I$(top_srcdir)/cut-n-paste/zoom-control/ \
-I$(top_srcdir)/cut-n-paste/toolbar-editor/ \
-I$(top_srcdir)/cut-n-paste/totem-screensaver/ \
@@ -9,10 +11,13 @@ INCLUDES= \
-I$(top_srcdir)/cut-n-paste/evmountoperation/ \
-I$(top_srcdir)/cut-n-paste/smclient/ \
-I$(top_srcdir)/libdocument \
+ -I$(top_builddir)/libdocument \
-I$(top_srcdir)/libview \
+ -I$(top_builddir)/libview \
-I$(top_srcdir)/properties \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
+ -DEVINCE_COMPILATION \
$(SHELL_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -95,7 +100,7 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/evmountoperation/libevmountoperation.la \
$(top_builddir)/cut-n-paste/smclient/libsmclient.la \
$(top_builddir)/properties/libevproperties.la \
- $(top_builddir)/libdocument/libevbackend.la \
+ $(top_builddir)/libdocument/libevdocument.la \
$(top_builddir)/libview/libevview.la \
$(SHELL_LIBS)