Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-04-08 13:10:00 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2009-04-08 13:10:00 (GMT)
commit5adc9f2e1a99e29b8a761388e17c08a6e4d79d5d (patch)
tree7f517616d8a21ef5184b7378915e1813c003b35a /shell/Makefile.am
parenta281d3cc1f64de07b4b8336c580ad4f5fcb861ed (diff)
Move EvPageAction and EvStockIcons from shell to a new internal library
2009-04-08 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * Makefile.am: * po/POTFILES.in: * shell/Makefile.am: * shell/ev-page-action-widget.[ch]: * shell/ev-page-action.[ch]: * shell/ev-stock-icons.[ch]: * shell/ev-application.c: * shell/main.c: * libmisc/Makefile.am: * libmisc/ev-page-action-widget.[ch]: * libmisc/ev-page-action.[ch]: * libmisc/ev-stock-icons.[ch]: Move EvPageAction and EvStockIcons from shell to a new internal library (libevmisc) that will be used by the evince previewer too. svn path=/trunk/; revision=3577
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 4230dbb..65d3ffa 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -14,6 +14,7 @@ INCLUDES= \
-I$(top_builddir)/libdocument \
-I$(top_srcdir)/libview \
-I$(top_builddir)/libview \
+ -I$(top_srcdir)/libmisc \
-I$(top_srcdir)/properties \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
@@ -53,10 +54,6 @@ evince_SOURCES= \
ev-navigation-action.h \
ev-navigation-action-widget.c \
ev-navigation-action-widget.h \
- ev-page-action.c \
- ev-page-action.h \
- ev-page-action-widget.c \
- ev-page-action-widget.h \
ev-password-view.h \
ev-password-view.c \
ev-print-operation.h \
@@ -87,8 +84,6 @@ evince_SOURCES= \
ev-sidebar-page.h \
ev-sidebar-thumbnails.c \
ev-sidebar-thumbnails.h \
- ev-stock-icons.c \
- ev-stock-icons.h \
main.c
evince_LDADD= \
@@ -102,6 +97,7 @@ evince_LDADD= \
$(top_builddir)/properties/libevproperties.la \
$(top_builddir)/libdocument/libevdocument.la \
$(top_builddir)/libview/libevview.la \
+ $(top_builddir)/libmisc/libevmisc.la \
$(SHELL_LIBS)
BUILT_SOURCES = ev-marshal.h ev-marshal.c