Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-10-19 17:27:45 (GMT)
committer Carlos Garcia Campos <carlosgc@gnome.org>2009-10-20 16:26:49 (GMT)
commit66e5636dcaace0d9a98845490b09721c12ce3d2b (patch)
treef59d5c02d4f30658b17f317944e2c86f77f8afdc /shell/Makefile.am
parent3f28adc16f40da7048d9693278ed2940aa1e39f0 (diff)
Run evince instances in different processes instead of single instance
- When built with DBus support a daemon is used to keep track of opened documents and reload them when reopened. - Crash recovery code has been removed. - Metadata migration code has been moved from main.c to ev-daemon.c, so that it's only run once on daemon startup. Fixes bgo#583680, bgo#434966, bgo#497388, bgo#524633 and bgo#586087.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am31
1 files changed, 29 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 3b4f6f7..8d86efe 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -26,6 +26,9 @@ INCLUDES= \
bin_PROGRAMS=evince
libexec_PROGRAMS=evince-convert-metadata
+if ENABLE_DBUS
+libexec_PROGRAMS += evinced
+endif
EV_MEDIA_PLAYER_KEYS_SOURCES = ev-media-player-keys.c ev-media-player-keys.h
if ENABLE_DBUS
@@ -119,10 +122,30 @@ evince_convert_metadata_SOURCES= \
evince_convert_metadata_LDADD= \
$(SHELL_LIBS)
+if ENABLE_DBUS
+BUILT_SOURCES += ev-daemon-service.h
+evinced_SOURCES= \
+ ev-daemon.c
+
+evinced_CFLAGS= \
+ -DDATADIR=\"$(pkgdatadir)\" \
+ -DGNOMEDATADIR=\"$(datadir)\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DEVINCE_COMPILATION \
+ $(EV_DAEMON_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+evinced_LDADD= \
+ $(EV_DAEMON_LIBS)
+endif
EXTRA_DIST = ev-marshal.list \
ev-application-service.xml \
+ ev-daemon-service.xml \
$(EV_MEDIA_PLAYER_KEYS_SOURCES)
@@ -133,8 +156,12 @@ ev-marshal.c: $(srcdir)/ev-marshal.list
echo '#include "ev-marshal.h"' > ev-marshal.c
$(AM_V_GEN)$(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --body >> ev-marshal.c
-DISTCLEANFILES= \
- ev-application-service.h
+DISTCLEANFILES= \
+ ev-application-service.h \
+ ev-daemon-service.h
ev-application-service.h: $(srcdir)/ev-application-service.xml
$(AM_V_GEN)dbus-binding-tool --prefix=ev_application --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
+
+ev-daemon-service.h: $(srcdir)/ev-daemon-service.xml
+ $(AM_V_GEN)dbus-binding-tool --prefix=ev_daemon --mode=glib-server --output=ev-daemon-service.h $(srcdir)/ev-daemon-service.xml