Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2008-08-31 15:20:43 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2008-08-31 15:20:43 (GMT)
commit83a7a11ba109b8aee5cdc047dec8b93967ccfc0e (patch)
treeadc1a8b56abf1f8bffc85a8faeb4e90e4ac2c71a /shell/Makefile.am
parent216f093dc323646d127a4b66af1179e6c1011f47 (diff)
EggSMClient copied from libegg
2008-08-31 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/Makefile.am: * cut-n-paste/smclient/Makefile.am: * cut-n-paste/smclient/eggdesktopfile.[ch]: * cut-n-paste/smclient/eggsmclient-private.h: * cut-n-paste/smclient/eggsmclient-xsmp.c: * cut-n-paste/smclient/eggsmclient.[ch]: EggSMClient copied from libegg * libdocument/ev-file-helpers.c: (ev_dot_dir): * shell/Makefile.am: * shell/ev-application.[ch]: (ev_application_load_session), (smclient_save_state_cb), (smclient_quit_cb), (ev_application_init_session), (ev_application_shutdown), (ev_application_init): * shell/main.c: (main): Use EggSMClient instead of gnome-client and remove libgnome and libgnomeui dependencies. svn path=/trunk/; revision=3130
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d2c14a9..16eeaf1 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -6,6 +6,7 @@ INCLUDES= \
-I$(top_srcdir)/cut-n-paste/totem-screensaver/ \
-I$(top_srcdir)/cut-n-paste/gedit-message-area/ \
-I$(top_srcdir)/cut-n-paste/evmountoperation/ \
+ -I$(top_srcdir)/cut-n-paste/smclient/ \
-I$(top_srcdir)/libdocument \
-I$(top_srcdir)/properties \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
@@ -102,6 +103,7 @@ evince_LDADD= \
$(top_builddir)/cut-n-paste/totem-screensaver/libtotemscrsaver.la \
$(top_builddir)/cut-n-paste/gedit-message-area/libgeditmsgarea.la \
$(top_builddir)/cut-n-paste/evmountoperation/libevmountoperation.la \
+ $(top_builddir)/cut-n-paste/smclient/libsmclient.la \
$(top_builddir)/properties/libevproperties.la \
$(top_builddir)/libdocument/libevbackend.la \
$(SHELL_LIBS)