Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2007-12-02 20:02:01 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2007-12-02 20:02:01 (GMT)
commitc37e94332ad3d4a33a38a29f9557b7838f955f10 (patch)
tree14e22988373f6b1b99dc8f9e44b3b2e8a4e62852 /shell/Makefile.am
parent595d902c5518765e086e8a911124ef36ed9300b7 (diff)
Use a message area instead of a popup dialog for error notifications.
2007-12-02 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * cut-n-paste/gedit-message-area/Makefile.am: * cut-n-paste/gedit-message-area/gedit-message-area.[ch]: * shell/Makefile.am: * shell/ev-message-area.[ch]: * shell/ev-window.c: (ev_window_set_message_area), (ev_window_error_message_response_cb), (ev_window_error_message), (ev_window_load_job_cb), (ev_window_cmd_file_open_copy_at_dest), (ev_window_save_job_cb), (image_save_dialog_response_cb), (ev_attachment_popup_cmd_open_attachment), (attachment_save_dialog_response_cb), (ev_window_set_document), (ev_window_init): Use a message area instead of a popup dialog for error notifications. Fixes bug #337495. svn path=/trunk/; revision=2757
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 34dc0ff..973882b 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -4,6 +4,7 @@ INCLUDES= \
-I$(top_srcdir)/cut-n-paste/zoom-control/ \
-I$(top_srcdir)/cut-n-paste/toolbar-editor/ \
-I$(top_srcdir)/cut-n-paste/totem-screensaver/ \
+ -I$(top_srcdir)/cut-n-paste/gedit-message-area/ \
-I$(top_srcdir)/libdocument \
-I$(top_srcdir)/properties \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
@@ -29,6 +30,8 @@ evince_SOURCES= \
ev-history.h \
ev-marshal.c \
ev-marshal.h \
+ ev-message-area.c \
+ ev-message-area.h \
ev-metadata-manager.c \
ev-metadata-manager.h \
ev-navigation-action.c \
@@ -89,13 +92,14 @@ evince_SOURCES+= \
endif
-evince_LDADD= \
- $(top_builddir)/cut-n-paste/zoom-control/libephyzoom.la \
- $(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
+evince_LDADD= \
+ $(top_builddir)/cut-n-paste/zoom-control/libephyzoom.la \
+ $(top_builddir)/cut-n-paste/toolbar-editor/libtoolbareditor.la \
$(top_builddir)/cut-n-paste/totem-screensaver/libtotemscrsaver.la \
- $(top_builddir)/properties/libevproperties.la \
- $(top_builddir)/libdocument/libevbackend.la \
- $(SHELL_LIBS) \
+ $(top_builddir)/cut-n-paste/gedit-message-area/libgeditmsgarea.la \
+ $(top_builddir)/properties/libevproperties.la \
+ $(top_builddir)/libdocument/libevbackend.la \
+ $(SHELL_LIBS) \
$(GNOME_PRINT_LIBS)
if ENABLE_DJVU