Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2009-01-25 15:08:57 (GMT)
committer Christian Persch <chpe@src.gnome.org>2009-01-25 15:08:57 (GMT)
commit4912987303aefef0d02a45726b75e5fdae043982 (patch)
tree3856f1dc17d3c927436672171532942b997dfe2b /thumbnailer/Makefile.am
parentb2c387604ca233c9c70a0595a24d381ddfafd1d4 (diff)
Renamed from evince-backend.pc.in. Renamed library to libevdocument.la.
* configure.ac: * evince-document.pc.in: Renamed from evince-backend.pc.in. * libdocument/Makefile.am: Renamed library to libevdocument.la. * libview/Makefile.am: * shell/Makefile.am: * backend/*/Makefile.am: Adapt to changed library name. * libdocument/Makefile.am: * libview/Makefile.am: Change the installed headers path to match the directory names in SVN. * evince-document.h: * evince-view.h: Add single headers. Bug #568227. * libdocument/*.h: * libview/*.h: Add single headers guards. * libview/Makefile.am: * libdocument/Makefile.am: * backend/*/Makefile.am: * help/reference/Makefile.am: Define EVINCE_COMPILATION, so we can still include individual headers. * properties/Makefile.am: * properties/ev-properties-main.c: * properties/ev-properties-view.h: * thumbnailer/Makefile.am: * thumbnailer/evince-thumbnailer.c: Include only evince-document.h. * libdocument/Makefile.am: * libview/Makefile.am: Generate type builtins from all installed headers. * libdocument/ev-link-action.[ch]: * libdocument/ev-link-dest.[ch]: * libdocument/ev-transition-effect.[ch]: * libview/ev-view.[ch]: Remove handcoded type builtins. * libdocument/Makefile.am: * evince-document.h: Add ev-document-factory.h to the public headers. svn path=/trunk/; revision=3381
Diffstat (limited to 'thumbnailer/Makefile.am')
-rw-r--r--thumbnailer/Makefile.am27
1 files changed, 16 insertions, 11 deletions
diff --git a/thumbnailer/Makefile.am b/thumbnailer/Makefile.am
index 19c2bee..c7b3c85 100644
--- a/thumbnailer/Makefile.am
+++ b/thumbnailer/Makefile.am
@@ -1,21 +1,26 @@
@INTLTOOL_SCHEMAS_RULE@
-INCLUDES= \
+bin_PROGRAMS = evince-thumbnailer
+
+evince_thumbnailer_SOURCES = \
+ evince-thumbnailer.c
+
+evince_thumbnailer_CPPFLAGS = \
-DDATADIR=\"$(pkgdatadir)\" \
- -I$(top_srcdir)/libdocument \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
- $(FRONTEND_CFLAGS) \
- $(DISABLE_DEPRECATED) \
- $(WARN_CFLAGS)
+ $(AM_CPPFLAGS)
-bin_PROGRAMS=evince-thumbnailer
-
-evince_thumbnailer_SOURCES= \
- evince-thumbnailer.c
+evince_thumbnailer_CFLAGS = \
+ $(FRONTEND_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(WARN_CFLAGS) \
+ $(AM_CFLAGS)
-evince_thumbnailer_LDADD= \
- $(top_builddir)/libdocument/libevbackend.la \
+evince_thumbnailer_LDADD = \
+ $(top_builddir)/libdocument/libevdocument.la \
$(FRONTEND_LIBS)
schema_files = \