Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorNickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-05 15:29:03 (GMT)
committer Nickolay V. Shmyrev <nshmyrev@src.gnome.org>2006-05-05 15:29:03 (GMT)
commit68525a359fcf1c2f857337aaac6508861d305cae (patch)
tree647bca454f21173e57a684ad3ae9f96872812f25 /thumbnailer/Makefile.am
parent194a13e3f28e0578796101163ddd1ee34b1a16e0 (diff)
Due to broken libtool that is unable to track dependencies
of noinst libraries we are forced to explicitely point libraries for binary. Fix for the bug #333334.
Diffstat (limited to 'thumbnailer/Makefile.am')
-rw-r--r--thumbnailer/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/thumbnailer/Makefile.am b/thumbnailer/Makefile.am
index 8e24731..3bce3f9 100644
--- a/thumbnailer/Makefile.am
+++ b/thumbnailer/Makefile.am
@@ -20,6 +20,17 @@ evince_thumbnailer_LDADD= \
$(FRONTEND_LIBS) \
$(DJVU_LIBS)
+if ENABLE_DJVU
+evince_thumbnailer_LDADD += $(DJVU_LIBS)
+endif
+
+if ENABLE_DJVU
+evince_thumbnailer_LDADD += -lkpathsea
+endif
+
+if WITH_TYPE1_FONTS
+evince_thumbnailer_LDADD += -lt1
+endif
schema_files = \
evince-thumbnailer-dvi.schemas.in \