Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorDavid Malcolm <dmalcolm@redhat.com>2005-04-18 20:37:04 (GMT)
committer David Malcolm <dave_malcolm@src.gnome.org>2005-04-18 20:37:04 (GMT)
commitf332d42bc834d6a7b0ec58bb8e073e63bc619f63 (patch)
treecccfc8a309b52f379be170146673cbfa5fd5b678 /thumbnailer/Makefile.am
parent594edf9b1277d5ec88892c2ea02c2bdc2f2e8b0e (diff)
New files, handling the mapping from mimetypes to backends
2005-04-18 David Malcolm <dmalcolm@redhat.com> * shell/ev-document-types.h: * shell/ev-document-types.c: New files, handling the mapping from mimetypes to backends * shell/ev-window.c: * thumbnailer/evince-thumbnailer.c: Use the ev-document-types code * shell/Makefile.am: Added new convenience library libevbackendfactory_la, containing the new mimetype->backend logic; moved the backends into it. * thumbnailer/Makefile.am: Make the thumbnailer link with the libevbackend.la convenience library, rather than having a duplicate of the backend logic here.
Diffstat (limited to 'thumbnailer/Makefile.am')
-rw-r--r--thumbnailer/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/thumbnailer/Makefile.am b/thumbnailer/Makefile.am
index c74910e..81575eb 100644
--- a/thumbnailer/Makefile.am
+++ b/thumbnailer/Makefile.am
@@ -7,6 +7,7 @@ INCLUDES= \
-I$(top_srcdir)/lib \
-I$(top_srcdir)/pdf \
-I$(top_srcdir)/backend \
+ -I$(top_srcdir)/shell \
-DGNOMELOCALEDIR=\"$(datadir)/locale\" \
-DGNOMEICONDIR=\""$(datadir)/pixmaps"\" \
$(THUMBNAILER_CFLAGS) \
@@ -19,11 +20,10 @@ evince_thumbnailer_SOURCES= \
evince-thumbnailer.c
$(NULL)
-evince_thumbnailer_LDADD= \
- $(THUMBNAILER_LIBS) \
+evince_thumbnailer_LDADD= \
+ $(THUMBNAILER_LIBS) \
$(top_builddir)/lib/libev.la \
- $(top_builddir)/pdf/libpdfdocument.la \
- $(top_builddir)/backend/libevbackend.la \
+ $(top_builddir)/shell/libevbackendfactory.la \
$(NULL)
pixmapdir = $(pkgdatadir)