Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 11 insertions, 47 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cd6f59..7d23c68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,53 +1,17 @@
-SUBDIRS = cut-n-paste po help data test
-
-# Backends
-
-if ENABLE_PDF
-SUBDIRS += pdf
-endif
-
-if ENABLE_PS
-SUBDIRS += ps
-endif
-
-if ENABLE_PIXBUF
-SUBDIRS += pixbuf
-endif
-
-if ENABLE_DJVU
-SUBDIRS += djvu
-endif
-
-if ENABLE_TIFF
-SUBDIRS += tiff
-endif
-
-if ENABLE_DVI
-SUBDIRS += dvi
-endif
-
-if ENABLE_COMICS
- SUBDIRS += comics
-endif
-
-if ENABLE_IMPRESS
- SUBDIRS += impress
-endif
-
-SUBDIRS += backend
-
-# Library
-
-SUBDIRS += lib
-
-# Properties (library and application)
-
-SUBDIRS += properties
+SUBDIRS = \
+ cut-n-paste \
+ po \
+ help \
+ data \
+ test \
+ backend \
+ libdocument \
+ properties \
+ shell \
+ thumbnailer
# Applications
-SUBDIRS += shell thumbnailer
-
intltool_extra = intltool-extract.in intltool-merge.in intltool-update.in
EXTRA_DIST = $(intltool_extra) gnome-doc-utils.make