Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/backend/ps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'backend/ps/Makefile.am')
-rw-r--r--backend/ps/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/backend/ps/Makefile.am b/backend/ps/Makefile.am
index e443b4a..921e397 100644
--- a/backend/ps/Makefile.am
+++ b/backend/ps/Makefile.am
@@ -5,8 +5,17 @@ INCLUDES = \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
+if HAVE_SPECTRE
+INCLUDES += $(SPECTRE_CFLAGS)
+endif
+
noinst_LTLIBRARIES = libpsdocument.la
+if HAVE_SPECTRE
+libpsdocument_la_SOURCES = \
+ ev-spectre.c \
+ ev-spectre.h
+else
libpsdocument_la_SOURCES = \
gsio.c \
gsio.h \
@@ -19,4 +28,4 @@ libpsdocument_la_SOURCES = \
ps-interpreter.h \
gsdefaults.c \
gsdefaults.h
-
+endif