Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/browser-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'browser-plugin/Makefile.am')
-rw-r--r--browser-plugin/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/browser-plugin/Makefile.am b/browser-plugin/Makefile.am
new file mode 100644
index 0000000..cbf7674
--- /dev/null
+++ b/browser-plugin/Makefile.am
@@ -0,0 +1,22 @@
+plugindir = ${libdir}/mozilla/plugins
+plugin_LTLIBRARIES = libevince-plugin.la
+
+libevince_plugin_la_SOURCES = \
+ glue.cpp \
+ plugin.cpp \
+ plugin.h \
+ scriptable.cpp \
+ scriptable.h
+
+libevince_plugin_la_CPPFLAGS = \
+ -I$(top_srcdir)/libview \
+ -DXP_UNIX \
+ -DMOZ_X11 \
+ $(BROWSER_PLUGIN_CFLAGS) \
+ $(AM_CPPFLAGS)
+
+libevince_plugin_la_LIBADD = \
+ $(top_builddir)/libview/libevview.la \
+ $(BROWSER_PLUGIN_LIBS)
+
+libevince_plugin_la_LDFLAGS = -avoid-version -module