Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/comics/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'comics/Makefile.am')
-rw-r--r--comics/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/comics/Makefile.am b/comics/Makefile.am
new file mode 100644
index 0000000..22c9290
--- /dev/null
+++ b/comics/Makefile.am
@@ -0,0 +1,25 @@
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/backend \
+ -I$(top_srcdir)/lib \
+ $(LIB_CFLAGS)
+
+noinst_LTLIBRARIES = libcomicsdocument.la
+
+libcomicsdocument_la_SOURCES = \
+ comics-document.c \
+ comics-document.h
+
+# need to respect $XDG_DATA_DIR probably
+xdgmimedir = $(gnome_data)/mime/packages
+xdgmime_DATA = ev-cbr-mime.xml
+
+EXTRA_DIST = $(xdgmime_DATA)
+
+install-data-hook:
+ update-mime-database $(gnome_data)/mime
+
+uninstall-hook:
+ update-mime-database $(gnome_data)/mime
+
+