Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d1f1ed7..41dd94a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,15 +196,24 @@ dnl ========= Check for GConf
AC_MSG_CHECKING([whether GConf support is requested])
AC_ARG_WITH([gconf],
[AS_HELP_STRING([--without-gconf],[disable the use of gconf])],
- [],[with_gconf=yes])
+ [],[with_gconf=check])
AC_MSG_RESULT([$with_gconf])
-AM_CONDITIONAL([WITH_GCONF],[test "$with_gconf" = "yes"])
-
-if test "$with_gconf" = "yes"; then
- PKG_CHECK_MODULES([GCONF],[gconf-2.0])
- AC_DEFINE([WITH_GCONF],[1],[Define if GConf support is enabled])
+if test "x$with_gconf" != "xno"; then
+ PKG_CHECK_MODULES([GCONF],[gconf-2.0],
+ with_gconf=yes,
+ if test "x$with_gconf" = "xcheck"; then
+ with_gconf=no
+ AC_MSG_WARN(The use of GConf is disabled since required library gconf-2.0 was not found.)
+ else
+ AC_MSG_FAILURE(GConf test failed: $GCONF_PKG_ERRORS)
+ fi
+ )
fi
+if test "x$with_gconf" = "xyes"; then
+ AC_DEFINE([WITH_GCONF],[1],[Define if GConf support is enabled])
+fi
+AM_CONDITIONAL([WITH_GCONF],[test "$with_gconf" = "yes"])
AM_GCONF_SOURCE_2