Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/smclient/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cut-n-paste/smclient/Makefile.am')
-rw-r--r--cut-n-paste/smclient/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/cut-n-paste/smclient/Makefile.am b/cut-n-paste/smclient/Makefile.am
new file mode 100644
index 0000000..3cb7725
--- /dev/null
+++ b/cut-n-paste/smclient/Makefile.am
@@ -0,0 +1,21 @@
+noinst_LTLIBRARIES = libsmclient.la
+
+libsmclient_la_SOURCES = \
+ eggdesktopfile.c \
+ eggdesktopfile.h \
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ eggsmclient-xsmp.c
+
+libsmclient_la_CFLAGS = \
+ -I$(top_srcdir)/lib \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ -DEGG_SM_CLIENT_BACKEND_XSMP \
+ $(SMCLIENT_CFLAGS) \
+ $(WARNING_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+libsmclient_la_LIBADD = \
+ $(SMCLIENT_LIBS) \
+ -lSM -lICE