Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/cut-n-paste/toolbar-editor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cut-n-paste/toolbar-editor/Makefile.am')
-rw-r--r--cut-n-paste/toolbar-editor/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/cut-n-paste/toolbar-editor/Makefile.am b/cut-n-paste/toolbar-editor/Makefile.am
new file mode 100644
index 0000000..7d57262
--- /dev/null
+++ b/cut-n-paste/toolbar-editor/Makefile.am
@@ -0,0 +1,35 @@
+
+INCLUDES = $(TOOLBAR_EDITOR_CFLAGS) \
+ -DCURSOR_DIR=\"$(pkgdatadir)\"
+
+BUILT_SOURCES = eggmarshalers.c eggmarshalers.h
+
+noinst_LTLIBRARIES = libtoolbareditor.la
+
+libtoolbareditor_la_SOURCES = \
+ egg-toolbars-model.c \
+ egg-editable-toolbar.c \
+ egg-toolbar-editor.c \
+ egg-marshal.c
+
+noinst_HEADERS = \
+ egg-toolbars-model.h \
+ egg-editable-toolbar.h \
+ egg-toolbar-editor.h
+
+eggmarshalers.h: eggmarshalers.list
+ cd $(srcdir) \
+ && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --header > xgen-emh \
+ && cp xgen-emh eggmarshalers.h \
+ && rm -f xgen-emh xgen-emh~
+
+eggmarshalers.c: eggmarshalers.list
+ cd $(srcdir) \
+ && $(GLIB_GENMARSHAL) --prefix=_egg_marshal eggmarshalers.list --body > xgen-emc \
+ && cp xgen-emc eggmarshalers.c \
+ && rm -f xgen-emc xgen-emc~
+
+egg-marshal.c: eggmarshalers.c eggmarshalers.h
+
+EXTRA_DIST= \
+ eggmarshalers.list