Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libview/Makefile.am')
-rw-r--r--libview/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/libview/Makefile.am b/libview/Makefile.am
index dfdb20e..e41b3a8 100644
--- a/libview/Makefile.am
+++ b/libview/Makefile.am
@@ -22,7 +22,8 @@ NOINST_H_FILES = \
INST_H_FILES = \
ev-jobs.h \
ev-page-cache.h \
- ev-view.h
+ ev-view.h \
+ ev-view-type-builtins.h
headerdir = $(prefix)/include/evince/@EV_API_VERSION@/ev-view
header_DATA = $(INST_H_FILES)
@@ -37,12 +38,15 @@ libevview_la_SOURCES = \
ev-view.c \
ev-view-accessible.c \
ev-view-marshal.c \
+ ev-view-type-builtins.c \
$(NOINST_H_FILES) \
$(INST_H_FILES)
BUILT_SOURCES = \
ev-view-marshal.h \
- ev-view-marshal.c
+ ev-view-marshal.c \
+ ev-view-type-builtins.c \
+ ev-view-type-builtins.h
CLEANFILES = $(BUILT_SOURCES)
@@ -54,3 +58,18 @@ ev-view-marshal.c: $(srcdir)/ev-view-marshal.list
$(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --body >> $@
EXTRA_DIST = ev-view-marshal.list
+
+ev-view-type-builtins.h: stamp-ev-view-type-builtins.h
+ @true
+
+stamp-ev-view-type-builtins.h: ev-view-type-builtins.h.template ev-job-scheduler.h
+ $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbh \
+ && (cmp -s xgen-etbh ev-view-type-builtins.h || cp xgen-etbh ev-view-type-builtins.h ) \
+ && rm -f xgen-etbh \
+ && echo timestamp > $(@F)
+
+ev-view-type-builtins.c: ev-view-type-builtins.c.template ev-job-scheduler.h
+ $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbc \
+ && (cmp -s xgen-etbc ev-view-type-builtins.c || cp xgen-etbc ev-view-type-builtins.c ) \
+ && rm -f xgen-etbc
+