Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libview/Makefile.am')
-rw-r--r--libview/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/libview/Makefile.am b/libview/Makefile.am
new file mode 100644
index 0000000..dfdb20e
--- /dev/null
+++ b/libview/Makefile.am
@@ -0,0 +1,56 @@
+INCLUDES= \
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ -I$(top_srcdir)/libdocument \
+ $(LIBVIEW_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+lib_LTLIBRARIES = libevview.la
+
+libevview_la_LDFLAGS = -export-dynamic
+libevview_la_LIBADD = $(LIBVIEW_LIBS)
+
+NOINST_H_FILES = \
+ ev-job-scheduler.h \
+ ev-pixbuf-cache.h \
+ ev-timeline.h \
+ ev-transition-animation.h \
+ ev-view-accessible.h \
+ ev-view-marshal.h \
+ ev-view-private.h
+
+INST_H_FILES = \
+ ev-jobs.h \
+ ev-page-cache.h \
+ ev-view.h
+
+headerdir = $(prefix)/include/evince/@EV_API_VERSION@/ev-view
+header_DATA = $(INST_H_FILES)
+
+libevview_la_SOURCES = \
+ ev-jobs.c \
+ ev-job-scheduler.c \
+ ev-page-cache.c \
+ ev-pixbuf-cache.c \
+ ev-timeline.c \
+ ev-transition-animation.c \
+ ev-view.c \
+ ev-view-accessible.c \
+ ev-view-marshal.c \
+ $(NOINST_H_FILES) \
+ $(INST_H_FILES)
+
+BUILT_SOURCES = \
+ ev-view-marshal.h \
+ ev-view-marshal.c
+
+CLEANFILES = $(BUILT_SOURCES)
+
+ev-view-marshal.h: $(srcdir)/ev-view-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --header > $@
+
+ev-view-marshal.c: $(srcdir)/ev-view-marshal.list
+ echo '#include "ev-view-marshal.h"' > ev-view-marshal.c
+ $(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --body >> $@
+
+EXTRA_DIST = ev-view-marshal.list