Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libview/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libview/Makefile.am')
-rw-r--r--libview/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/libview/Makefile.am b/libview/Makefile.am
index 3a16b26..bb563a4 100644
--- a/libview/Makefile.am
+++ b/libview/Makefile.am
@@ -1,3 +1,5 @@
+QUIET_GEN = $(Q:@=@echo ' GEN '$@;)
+
lib_LTLIBRARIES = libevview.la
NOINST_H_FILES = \
@@ -71,23 +73,23 @@ BUILT_SOURCES = \
CLEANFILES = $(BUILT_SOURCES) stamp-ev-view-type-builtins.h
ev-view-marshal.h: $(srcdir)/ev-view-marshal.list
- $(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --header --internal > $@
+ $(QUIET_GEN)$(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --header --internal > $@
ev-view-marshal.c: $(srcdir)/ev-view-marshal.list
- echo '#include <config.h>' > ev-view-marshal.c
+ $(QUIET_GEN)echo '#include <config.h>' > ev-view-marshal.c
$(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --header --internal --body >> $@
ev-view-type-builtins.h: stamp-ev-view-type-builtins.h
@true
stamp-ev-view-type-builtins.h: ev-view-type-builtins.h.template $(INST_H_FILES)
- $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbh \
+ $(QUIET_GEN)$(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbh \
&& (cmp -s xgen-etbh ev-view-type-builtins.h || cp xgen-etbh ev-view-type-builtins.h ) \
&& rm -f xgen-etbh \
&& echo timestamp > $(@F)
ev-view-type-builtins.c: ev-view-type-builtins.c.template $(INST_H_FILES)
- $(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbc \
+ $(QUIET_GEN)$(GLIB_MKENUMS) --template $< $(filter-out $<,$^) > xgen-etbc \
&& (cmp -s xgen-etbc ev-view-type-builtins.c || cp xgen-etbc ev-view-type-builtins.c ) \
&& rm -f xgen-etbc