Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/pdf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pdf/Makefile.am')
-rw-r--r--pdf/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/pdf/Makefile.am b/pdf/Makefile.am
index b8fe1da..4604706 100644
--- a/pdf/Makefile.am
+++ b/pdf/Makefile.am
@@ -1,3 +1,27 @@
-SUBDIRS = goo fofi splash xpdf
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/backend \
+ $(POPPLER_CFLAGS) \
+ $(GTK_CFLAGS) \
+ -DDATADIR=\""$(datadir)"\"
-EXTRA_DIST = aconf.h aconf2.h
+noinst_PROGRAMS = test-gdk-output-dev
+
+noinst_LTLIBRARIES = libpdfdocument.la
+
+libpdfdocument_la_SOURCES = \
+ GDKSplashOutputDev.cc \
+ GDKSplashOutputDev.h \
+ Thumb.cc \
+ Thumb.h \
+ pdf-document.cc \
+ pdf-document.h
+
+test_gdk_output_dev_SOURCES = \
+ test-gdk-output-dev.cc
+
+test_gdk_output_dev_LDADD = \
+ libpdfdocument.la \
+ $(top_builddir)/backend/libevbackend.la \
+ $(POPPLER_LIBS) \
+ $(GTK_LIBS)