Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 43279e5..3e1c2b7 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -30,7 +30,6 @@ libevbackendfactory_la_SOURCES= \
libevbackendfactory_la_LIBADD = \
$(top_builddir)/pdf/libpdfdocument.la \
$(top_builddir)/pixbuf/libpixbufdocument.la \
- $(top_builddir)/tiff/libtiffdocument.la \
$(top_builddir)/ps/libgtkgs.la \
$(top_builddir)/backend/libevbackend.la \
$(NULL)
@@ -41,6 +40,12 @@ libevbackendfactory_la_LIBADD += \
$(NULL)
endif
+if ENABLE_TIFF
+libevbackendfactory_la_LIBADD += \
+ $(top_builddir)/tiff/libtiffdocument.la \
+ $(NULL)
+endif
+
if ENABLE_DVI
libevbackendfactory_la_LIBADD += \
$(top_builddir)/dvi/libgtkdvi.la \
@@ -86,7 +91,6 @@ evince_SOURCES= \
evince_LDADD= \
$(SHELL_LIBS) \
- $(LIBTIFF) \
$(top_builddir)/cut-n-paste/recent-files/librecent.la \
$(top_builddir)/cut-n-paste/zoom-control/libephymisc.la \
$(top_builddir)/cut-n-paste/zoom-control/libephywidgets.la \