Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 737fccf..0262c37 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,3 +1,5 @@
+QUIET_GEN = $(Q:@=@echo ' GEN '$@;)
+
INCLUDES= \
-DDATADIR=\"$(pkgdatadir)\" \
-DGNOMEDATADIR=\"$(datadir)\" \
@@ -110,10 +112,10 @@ EXTRA_DIST = ev-marshal.list \
ev-marshal.h: $(srcdir)/ev-marshal.list
- $(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --header > ev-marshal.h
+ $(QUIET_GEN)$(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --header > ev-marshal.h
ev-marshal.c: $(srcdir)/ev-marshal.list
- echo '#include "ev-marshal.h"' > ev-marshal.c
+ $(QUIET_GEN)echo '#include "ev-marshal.h"' > ev-marshal.c
$(GLIB_GENMARSHAL) --prefix=ev_marshal $(srcdir)/ev-marshal.list --body >> ev-marshal.c
DISTCLEANFILES= \
@@ -121,8 +123,8 @@ DISTCLEANFILES= \
if DBUS_TOOL_NO_PREFIX
ev-application-service.h: $(srcdir)/ev-application-service.xml
- dbus-binding-tool --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
+ $(QUIET_GEN)dbus-binding-tool --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
else
ev-application-service.h: $(srcdir)/ev-application-service.xml
- dbus-binding-tool --prefix=ev_application --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
+ $(QUIET_GEN)dbus-binding-tool --prefix=ev_application --mode=glib-server --output=ev-application-service.h $(srcdir)/ev-application-service.xml
endif