Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index da0d875..d2aec6d 100644
--- a/configure.in
+++ b/configure.in
@@ -267,6 +267,20 @@ AC_ARG_ENABLE(sqlite,
with_sqlite="$enableval", with_sqlite="yes")
AC_MSG_RESULT($with_sqlite)
+dnl GNET support
+AC_MSG_CHECKING([wether we build with GNET (if not, networking will be disabled)])
+AC_ARG_ENABLE(gnet,
+ AC_HELP_STRING(
+ [--disable-gnet],
+ [Turn on gnet (will let GCompris fetch content from a web server)]),
+ with_gnet="$enableval", with_gnet="no")
+AC_MSG_RESULT($with_gnet)
+
+if test x$with_gnet = xyes; then
+ PKG_CHECK_MODULES(GNET, gnet-2.0,, AC_MSG_ERROR([*** GNET not found!]))
+ AC_DEFINE([USE_GNET], 1,[Networking is enabled])
+fi
+
dnl check for python
AC_ARG_WITH(python,AC_HELP_STRING(
[--with-python=path],
@@ -501,6 +515,8 @@ echo "XF86VM option (--enable-xf86vidmode) = $found_xf86vidmode"
echo "SQLITE database (--enable-sqlite) = $with_sqlite (profiles depend on this)"
+echo "GNET Networking (--enable-gnet) = $with_gnet (networking depends on this)"
+
echo
echo gcompris will be installed in ${prefix}
echo to compile and install in in another directory