Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorIgnacio Rodríguez <ignacio@sugarlabs.org>2013-01-06 22:13:53 (GMT)
committer Ignacio Rodríguez <ignacio@sugarlabs.org>2013-01-06 22:13:53 (GMT)
commit2bdb16a1f41552cf7bdd45e1fb2d7a3e3cadf9df (patch)
tree7f0776c143a2d8c496cca955f65ad8de0cbde0a3 /setup.py
parent9a70e542352b3b9e1b6a45d54627c6751c03e265 (diff)
Port finish.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py34
1 files changed, 3 insertions, 31 deletions
diff --git a/setup.py b/setup.py
index e5026ee..9c64384 100755
--- a/setup.py
+++ b/setup.py
@@ -1,32 +1,4 @@
#!/usr/bin/env python
-import os
-import sys
-
-if len(sys.argv) > 1 and '--no-sugar' == sys.argv[1]:
- # Remove the argument from the stack so we don't cause problems
- # for distutils
- sys.argv.pop(1)
-
- import glob, os.path, string
- from distutils.core import setup
-
- DATA_FILES = [
- ('icons', glob.glob('icons/*')),
- ('images', glob.glob('images/*')),
- ('/usr/share/applications', ['turtleart.desktop'])
- ]
-
- setup (name = 'Turtle Art',
- description = "A LOGO-like tool for teaching programming",
- author = "Walter Bender",
- author_email = "walter.bender@gmail.com",
- version = '0.9.4',
- packages = ['TurtleArt'],
- scripts = ['turtleart'],
- data_files = DATA_FILES,
- )
-else:
- from sugar.activity import bundlebuilder
-
- if __name__ == "__main__":
- bundlebuilder.start()
+from sugar3.activity import bundlebuilder
+if __name__ == "__main__":
+ bundlebuilder.start()