Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..e3052d1
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,11 @@
+#!/usr/bin/env python
+try:
+ from sugar.activity import bundlebuilder
+ bundlebuilder.start("ImageQuiz")
+except ImportError:
+ import os
+ os.system("find ./ | sed 's,^./,ImageQuiz.activity/,g' > MANIFEST")
+ os.chdir('..')
+ os.system('zip -r ImageQuiz.xo ImageQuiz.activity')
+ os.system('mv ImageQuiz.xo ./ImageQuiz.activity')
+ os.chdir('ImageQuiz.activity')