Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules4
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 33d6b04..24db475 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ sugar-hulahop (0.4.0-1) unstable; urgency=low
* Bump debhelper compatibility level to 6 (was 5).
* Add watch file.
* Add URL to upstream tarball source in debian/copyright.
+ * Remove autogenerated files in clean target not in upstream tarball
+ (confuses copyright-check.mk).
* Tighten (build-)dependency on xulrunner, and rewrite to only declare
version number once for both dependency and build-dependencies.
* Update local cdbs snippets:
diff --git a/debian/rules b/debian/rules
index 2182494..9057a0c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,10 @@ pkg = python-hulahop
# Woraround for type punning causing "size of array 'arg' is negative"
CXXFLAGS += -fno-strict-aliasing
+# Remove autogenerated files.
+clean::
+ rm -f python/config.py python/hulahop.c
+
# Minimum usable version of xulrunner
python-xpcom-minver = 1.9~rc2