Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9a9dca2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2008 Jonas Smedegaard <dr@jones.dk>
+
+# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
+DEB_BUILDDIR = build
+DEB_PYTHON_SYSTEM = pycentral
+ifneq (,$(DEB_MAINTAINER_MODE))
+ # Enable stuff not policy compliant (eg. unsuitable for build daemons)
+ DEB_COPYRIGHT_CHECK_STRICT = yes
+ DEB_AUTO_UPDATE_DEBIAN_CONTROL = yes
+endif
+include debian/cdbs/1/rules/upstream-tarball.mk
+include debian/cdbs/1/rules/copyright-check.mk
+include debian/cdbs/1/class/python-autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/1/rules/buildinfo.mk
+
+pkg = sugar-presence-service
+
+DEB_UPSTREAM_URL = http://dev.laptop.org/pub/sugar/sources/$(DEB_UPSTREAM_PACKAGE)
+DEB_UPSTREAM_TARBALL_EXTENSION = tar.bz2
+DEB_UPSTREAM_TARBALL_MD5 = f9c550f4f05c333a472d7576c6075720
+
+DEB_MAKE_CHECK_TARGET = check
+
+# Needed by upstream unittests
+# pygtk << 2.9 contained gobject
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-dbus, python-gobject | python-gtk2 (<< 2.9)
+
+# Resolve, cleanup and apply CDBS-declared dependencies
+include debian/cdbs/1/rules/package-relations.mk