Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJustin Gallardo <jirwin@eleanor.(none)>2006-11-29 22:27:56 (GMT)
committer Justin Gallardo <jirwin@eleanor.(none)>2006-11-29 22:27:56 (GMT)
commit88149a34f5d5328ab26505b98651b07fff9786db (patch)
treee1eb8f030a3f57d68952ffa91c187a43d8dd59b6 /setup.py
parente3a2814fa4243f5f2b89fba42ce47ad7954d77ed (diff)
Updated setup.py to use bundlebuilder
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py87
1 files changed, 2 insertions, 85 deletions
diff --git a/setup.py b/setup.py
index bf7514f..876cd3f 100755
--- a/setup.py
+++ b/setup.py
@@ -16,90 +16,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-import sys
-import os
-import zipfile
+from sugar.activity import bundlebuilder
-from sugar.activity.bundle import Bundle
+bundlebuilder.start()
-class SvnFileList(list):
- def __init__(self):
- f = os.popen('svn list -R')
- for line in f.readlines():
- filename = line.strip()
- if os.path.isfile(filename):
- self.append(filename)
- f.close()
-
-class GitFileList(list):
- def __init__(self):
- f = os.popen('git-ls-files')
- for line in f.readlines():
- filename = line.strip()
- if not filename.startswith('.'):
- self.append(filename)
- f.close()
-
-def get_source_path():
- return os.path.dirname(os.path.abspath(__file__))
-
-def get_activities_path():
- path = os.path.expanduser('~/Activities')
- if not os.path.isdir(path):
- os.mkdir(path)
- return path
-
-def get_bundle_dir():
- bundle_name = os.path.basename(get_source_path())
- return bundle_name + '.activity'
-
-def get_bundle_path():
- return os.path.join(get_activities_path(), get_bundle_dir())
-
-def print_help():
- print 'Usage: \n\
-setup.py dev - setup for development \n\
-setup.py package - create a bundle package \n\
-setup.py help - print this message \n\
-'
-
-def setup_dev():
- bundle_path = get_bundle_path()
- try:
- os.symlink(get_source_path(), bundle_path)
- except OSError:
- if os.path.islink(bundle_path):
- print 'ERROR - The bundle has been already setup for development.'
- else:
- print 'ERROR - A bundle with the same name is already installed.'
-
-def build_package():
- orig_path = os.getcwd()
- os.chdir(get_source_path())
-
- if os.path.isdir('.git'):
- file_list = GitFileList()
- elif os.path.isdir('.svn'):
- file_list = SvnFileList()
- else:
- print 'ERROR - The command works only with git or svn repositories.'
-
- bundle = Bundle(get_source_path())
-
- zipname = '%s-%d.xo' % (bundle.get_name(), bundle.get_activity_version())
- bundle_zip = zipfile.ZipFile(zipname, 'w')
-
- for filename in file_list:
- arcname = os.path.join(get_bundle_dir(), filename)
- bundle_zip.write(filename, arcname)
-
- bundle_zip.close()
-
- os.chdir(orig_path)
-
-if len(sys.argv) < 2 or sys.argv[1] == 'help':
- print_help()
-elif sys.argv[1] == 'dev':
- setup_dev()
-elif sys.argv[1] == 'package':
- build_package()