Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8218d91..d73238b 100644
--- a/configure.in
+++ b/configure.in
@@ -93,10 +93,13 @@ AC_ARG_WITH(png,
fi
])
AC_ARG_WITH(gsl,
- [ --with-gsl=yes/no enables/disables GSL complex routines],[
+ [ --with-gsl=yes/static/no enables/disables GSL complex routines],[
if test x$withval = xyes; then
gsl=yes
fi
+ if test x$withval = xstatic; then
+ gsl=static
+ fi
if test x$withval = xno; then
gsl=no
fi
@@ -438,6 +441,11 @@ if test $sffe = yes; then
echo "Complex math parser:"
echo "try GSL: $gsl"
+ if test $gsl = static; then
+ GSL_LIBS_PRE='-Wl,-Bstatic'
+ GSL_LIBS_POST='-Wl,-Bdynamic'
+ gsl=yes
+ fi
if test $gsl = yes; then
GSL_LIBS=""
AC_PATH_PROG(GSL_CONFIG, gsl-config, no)
@@ -448,7 +456,7 @@ if test $sffe = yes; then
else
AC_MSG_RESULT(yes)
echo "using GSL for complex numbers"
- GSL_LIBS=`$GSL_CONFIG --libs`
+ GSL_LIBS="$GSL_LIBS_PRE `$GSL_CONFIG --libs` $GSL_LIBS_POST"
GSL_CFLAGS=`$GSL_CONFIG --cflags`
CFLAGS="$CFLAGS $GSL_CFLAGS -fomit-frame-pointer -DSFFE_USING -DSFFE_CMPLX_GSL"
DRIVERLIBS="$DRIVERLIBS lib/libsffe.a"