Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e252af..d024f44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+TESTS_TMPDIR=$(abs_builddir)/tests-tmp
+
SUBDIRS = bin data po src extensions
DISTCLEANFILES = \
@@ -12,3 +14,9 @@ EXTRA_DIST = \
intltool-extract.in
DISTCHECK_CONFIGURE_FLAGS = --disable-update-mimedb
+
+test:
+ cd $(top_srcdir)/tests && \
+ mkdir -p $(TESTS_TMPDIR) && \
+ TMPDIR=$(TESTS_TMPDIR) python -m unittest discover && \
+ rm -rf $(TESTS_TMPDIR)