Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@localhost.localdomain>2007-05-21 09:06:52 (GMT)
committer Marco Pesenti Gritti <marco@localhost.localdomain>2007-05-21 09:06:52 (GMT)
commit42f7eeedc8d21a51fa6097333996b9111c80cbca (patch)
tree1205c68550a384ebde421e02d608112863e6e52d /configure.ac
parent6c671fb7fe11c7b146ed8496f8fd2505dce7bcae (diff)
Drop the browser stuff, it will be replaced by hulahop.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 0 insertions, 52 deletions
diff --git a/configure.ac b/configure.ac
index 6f4f2a3..520ad93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,59 +27,12 @@ PKG_CHECK_MODULES(PYGTK, pygtk-2.0)
PKG_CHECK_MODULES(PYCAIRO, pycairo)
-PKG_CHECK_MODULES(LIB, gtk+-2.0)
-
PKG_CHECK_MODULES(SHELL, gtk+-2.0 gstreamer-0.10 gstreamer-plugins-base-0.10)
PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
AC_SUBST(PYGTK_DEFSDIR)
#
-# Mozilla
-#
-
-AC_ARG_WITH(libxul_sdk,
- AC_HELP_STRING([--with-libxul-sdk=DIR], [Path to libxul SDK]))
-
-if test -d "$with_libxul_sdk"; then
-
-# xulrunner 1.9
-
-GECKO_CFLAGS="-I$with_libxul_sdk/sdk/include -DXPCOM_GLUE"
-XPCOMGLUE_LIBS="-L$with_libxul_sdk/sdk/lib -lxpcomglue"
-MOZILLA_INCLUDE_DIR="$with_libxul_sdk/include"
-XPIDL="$with_libxul_sdk/sdk/bin/xpidl"
-MOZILLA_IDL_DIR="$with_libxul_sdk/sdk/idl"
-
-AC_SUBST(XPCOMGLUE_LIBS)
-AC_SUBST(GECKO_CFLAGS)
-AC_SUBST(MOZILLA_INCLUDE_DIR)
-AC_SUBST(XPIDL)
-AC_SUBST(MOZILLA_IDL_DIR)
-
-PKG_CHECK_MODULES(NSPR, [nspr],
- [have_nspr=true],
- [
-PKG_CHECK_MODULES(NSPR, [mozilla-nspr],
- [have_nspr=true],
- [
-PKG_CHECK_MODULES(NSPR, [xulrunner-nspr],
- [have_nspr=true],
- have_nspr=false)
- ])
- ])
-
-if test "x$have_nspr" = xfalse; then
- AC_MSG_ERROR([Could not find nspr])
-fi
-
-else
-
-AC_MSG_ERROR([Must specify the xulrunner sdk dir (--with-libxul-sdk)])
-
-fi
-
-#
# Setup GETTEXT
#
ALL_LINGUAS="it ha ig yo"
@@ -95,10 +48,6 @@ AC_OUTPUT([
Makefile
bin/Makefile
data/Makefile
-browser/Makefile
-browser/components/Makefile
-browser/components/sessionstore/Makefile
-browser/components/browserhelper/Makefile
services/Makefile
services/presence/Makefile
services/clipboard/Makefile
@@ -129,7 +78,6 @@ services/console/interface/logviewer/Makefile
services/console/interface/terminal/Makefile
sugar/Makefile
sugar/activity/Makefile
-sugar/browser/Makefile
sugar/clipboard/Makefile
sugar/graphics/Makefile
sugar/p2p/Makefile