Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/bindings/globalkeys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/globalkeys/Makefile.am')
-rw-r--r--bindings/globalkeys/Makefile.am35
1 files changed, 0 insertions, 35 deletions
diff --git a/bindings/globalkeys/Makefile.am b/bindings/globalkeys/Makefile.am
deleted file mode 100644
index cd2175b..0000000
--- a/bindings/globalkeys/Makefile.am
+++ /dev/null
@@ -1,35 +0,0 @@
-INCLUDES = \
- $(WARN_CFLAGS) \
- $(PYTHON_INCLUDES) \
- $(PYGTK_CFLAGS) \
- $(GLOBALKEYS_CFLAGS)
-
-globalkeysdir = $(pkgdatadir)/bindings
-pkgpyexecdir = $(globalkeysdir)
-
-pkgpyexec_LTLIBRARIES = globalkeys.la
-
-globalkeys_la_LDFLAGS = -module -avoid-version
-globalkeys_la_LIBADD = $(GLOBALKEYS_LIBS)
-
-globalkeys_la_SOURCES = \
- eggaccelerators.c \
- eggaccelerators.h \
- globalkeysmodule.c \
- sugar-key-grabber.h \
- sugar-key-grabber.c
-
-nodist_globalkeys_la_SOURCES = globalkeys.c
-
-globalkeys.c: globalkeys.defs globalkeys.override
-
-CLEANFILES = globalkeys.c
-EXTRA_DIST = globalkeys.override globalkeys.defs
-
-.defs.c:
- (cd $(srcdir)\
- && $(PYGTK_CODEGEN) \
- --override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
- && cp gen-$*.c $*.c \
- && rm -f gen-$*.c