Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9163a6a..0b2de6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,18 @@ AC_SUBST(GECKO_CFLAGS)
AC_DEFINE([HAVE_GECKO_1_9],[1],[Define if we have gecko 1.9])
+PKG_CHECK_MODULES(NSPR, [nspr],
+ [have_nspr=true],
+ [
+PKG_CHECK_MODULES(NSPR, [mozilla-nspr],
+ [have_nspr=true],
+ have_nspr=false)
+ ])
+
+if test "x$have_nspr" = xfalse; then
+ AC_MSG_ERROR([Could not find nspr])
+fi
+
else
# xulrunner 1.8