Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/threadframe/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'threadframe/Makefile.am')
-rw-r--r--threadframe/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/threadframe/Makefile.am b/threadframe/Makefile.am
index e2cbd43..01ce6b1 100644
--- a/threadframe/Makefile.am
+++ b/threadframe/Makefile.am
@@ -1,13 +1,6 @@
-all:
- python setup.py build
+INCLUDES = $(PYTHON_INCLUDES)
-install:
- python setup.py install --prefix=${prefix}
-
-uninstall:
- rm -f ${prefix}/lib/python2.4/site-packages/threadframe.so
-
-clean:
- python setup.py clean
- -rm -rf build
- -rm -f core *~ *.so *.o *.pyd *.a python*.def
+threadframedir = $(pyexecdir)
+threadframe_la_LDFLAGS = -module -avoid-version
+threadframe_LTLIBRARIES = threadframe.la
+threadframe_la_SOURCES = threadframemodule.c