Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/threadframe/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'threadframe/setup.py')
-rw-r--r--threadframe/setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/threadframe/setup.py b/threadframe/setup.py
new file mode 100644
index 0000000..df8f46d
--- /dev/null
+++ b/threadframe/setup.py
@@ -0,0 +1,21 @@
+from distutils.core import setup
+from distutils.extension import Extension
+
+setup(
+ name = 'threadframe',
+ version = '0.2',
+ description = "Advanced thread debugging extension",
+ long_description = "Obtaining tracebacks on other threads than the current thread",
+ url = 'http://www.majid.info/mylos/stories/2004/06/10/threadframe.html',
+ maintainer = 'Fazal Majid',
+ maintainer_email = 'threadframe@majid.info',
+ license = 'Python',
+ platforms = [],
+ keywords = ['threading', 'thread'],
+
+ ext_modules=[
+ Extension('threadframe',
+ ['threadframemodule.c'],
+ ),
+ ],
+)