Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-06-22 12:14:27 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-06-22 12:14:27 (GMT)
commit147953366179680642d1abbf17f48e35f7482f1d (patch)
treeda480ad004880fff214f8b07458b4795cb1291af
parentbda1e0cf2949dc6da3d892d1cf492a0905bbcff9 (diff)
Add a make shell command
-rw-r--r--Makefile3
-rw-r--r--README12
-rw-r--r--TODO1
3 files changed, 15 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ec07682..09c671d 100644
--- a/Makefile
+++ b/Makefile
@@ -46,6 +46,9 @@ build-%:
run:
xinit $(SCRIPTS)/xinitrc -- :99
+shell:
+ $(JHBUILD) shell
+
bug-report:
@$(SCRIPTS)/bug-report
diff --git a/README b/README
index df747ef..ffae342 100644
--- a/README
+++ b/README
@@ -23,6 +23,17 @@ Run the commands
That should be all you need to have sugar running!
+= Developing =
+
+You can find all the sources in sugar-build/source. Before running any module
+build command make sure to be inside a shell, so that the environment is
+properly setup. For example if you wanted to make changes to the sugar module
+you could
+
+ make shell
+ cd source/sugar
+ make install
+
= Commands reference =
make build Build everything.
@@ -30,6 +41,7 @@ make run Run sugar.
make build-[module] Build a single module.
make clean Delete build artifacts and sources.
make bug-report Generate a bug report.
+make shell Open a shell with proper build environment.
= Environment variables =
diff --git a/TODO b/TODO
index 054bbe4..e69de29 100644
--- a/TODO
+++ b/TODO
@@ -1 +0,0 @@
-* Figure out how to change source and install, for a single module