Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-24 23:19:24 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-24 23:19:24 (GMT)
commit26302ce44039a55a460e2f969d517e7cd02f1cf7 (patch)
tree5ba903e46fe3c9f962b0bf105357f8918a378e20
parent5f84386aac98da24363e7d6fa2b37b4e0686fdbd (diff)
Couple of upload-snapshot fixes
-rw-r--r--Makefile.buildbot2
-rwxr-xr-xcommands/helpers/build-snapshot2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.buildbot b/Makefile.buildbot
index 3f1cde9..60d6d8a 100644
--- a/Makefile.buildbot
+++ b/Makefile.buildbot
@@ -9,7 +9,7 @@ SNAPSHOT_DEST=$(SNAPSHOT_DEST_HOST):$(SNAPSHOT_DEST_DIR)$(SUGAR_BUILDBOT)
upload-docs:
rsync -r --progress $(DOCS_SOURCE) $(DOCS_DEST)
-upload-snapshot:
+upload-snapshot: helpers-build
@TMP_DIR=`mktemp -td sugar-build-snapshot-XXXX` && \
echo "Creating snapshot" && \
SNAPSHOT_PATH=`commands/helpers/build-snapshot $$TMP_DIR` && \
diff --git a/commands/helpers/build-snapshot b/commands/helpers/build-snapshot
index 339cebf..ce749bf 100755
--- a/commands/helpers/build-snapshot
+++ b/commands/helpers/build-snapshot
@@ -65,4 +65,4 @@ rm -rf sugar-build
xz $filename
-echo $filename.xz
+echo $destdir/$filename.xz