Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-06-26 10:24:17 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-06-26 10:24:17 (GMT)
commit30ed5839458e8039e1656b161d6964aca1d96995 (patch)
tree4590ae0c65d1ac990b0674a789f11d53ab570979
parentd0f143a268283377041a0d903645a790391f54d4 (diff)
Jump into source and show the directory in PS1
Useful to know where you are
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e41df85..68b8057 100644
--- a/Makefile
+++ b/Makefile
@@ -47,10 +47,11 @@ run:
xinit $(SCRIPTS)/xinitrc -- :99
shell:
- @PS1="[sugar-build]$$ " \
- PATH=$(PATH):$(SCRIPTS)/shell \
- SUGAR_BUILD_SHELL=yes \
- $(JHBUILD) shell
+ @cd source; \
+ PS1="[sugar-build \W]$$ " \
+ PATH=$(PATH):$(SCRIPTS)/shell \
+ SUGAR_BUILD_SHELL=yes \
+ $(JHBUILD) shell
bug-report:
@$(SCRIPTS)/bug-report