Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-28 17:13:14 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-12-28 17:13:14 (GMT)
commit69bc89f42f2108a632105f0014ac9107a55a385c (patch)
tree30a065c8d217030a8ff6feea493e8f939bd50d52
parent4220aeb1963979971d498203b2d33d37c3b3d210 (diff)
Split buildbot in docs/snapshot
-rw-r--r--Makefile3
-rw-r--r--Makefile.docs5
-rw-r--r--Makefile.snapshot (renamed from Makefile.buildbot)8
3 files changed, 7 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 86ce2d7..7d36a19 100644
--- a/Makefile
+++ b/Makefile
@@ -12,5 +12,6 @@ all: build
include Makefile.config
include Makefile.commands
-include Makefile.buildbot
+include Makefile.snapshot
+include Makefile.docs
include Makefile.check
diff --git a/Makefile.docs b/Makefile.docs
new file mode 100644
index 0000000..7a9b6fb
--- /dev/null
+++ b/Makefile.docs
@@ -0,0 +1,5 @@
+DOCS_SOURCE=$(BUILD_DIR)/sugar-docs/html/
+DOCS_DEST=dnarvaez@shell.sugarlabs.org:~/public_html/sugar-docs/
+
+docs-upload:
+ rsync -r --progress $(DOCS_SOURCE) $(DOCS_DEST)
diff --git a/Makefile.buildbot b/Makefile.snapshot
index 357cd4b..c439cef 100644
--- a/Makefile.buildbot
+++ b/Makefile.snapshot
@@ -1,6 +1,3 @@
-DOCS_SOURCE=$(BUILD_DIR)/sugar-docs/html/
-DOCS_DEST=dnarvaez@shell.sugarlabs.org:~/public_html/sugar-docs/
-
SNAPSHOT_DEST_HOST=dnarvaez@shell.sugarlabs.org
SNAPSHOT_DEST_ROOT=/home/dnarvaez/public_html/snapshots/
SNAPSHOT_DEST_DIR=$(SUGAR_BUILDBOT)
@@ -9,11 +6,6 @@ SNAPSHOT_FILENAME=sugar-snapshot.tar
SNAPSHOT_PATH=$(SNAPSHOT_TMP_DIR)/$(SNAPSHOT_FILENAME)
SNAPSHOT_TMP_DIR:=$(shell mktemp -dut sugar-snapshot-XXXXXXXX)
-.PHONY: upload-docs upload-snapshot
-
-docs-upload:
- rsync -r --progress $(DOCS_SOURCE) $(DOCS_DEST)
-
snapshot-build:
@echo "Creating snapshot"
@$(TOOLS_DIR)/build-snapshot $(SNAPSHOT_PATH)