Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-25 22:22:37 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-25 22:22:37 (GMT)
commita0b65ee79f9f5abdee931aa02a3018cb308f6c51 (patch)
tree67eaf49d432f99e8a83684b64080b3163320a87a
parent1ea3e9a9f1e3cdfda24857b278518845f7ef2e18 (diff)
Check system directly in the commands
-rw-r--r--Makefile.commands2
-rwxr-xr-xcommands/helpers/build2
-rwxr-xr-xcommands/helpers/build-snapshot2
-rwxr-xr-xcommands/run2
-rw-r--r--devbot/system.py2
5 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.commands b/Makefile.commands
index 07b71b6..3b34341 100644
--- a/Makefile.commands
+++ b/Makefile.commands
@@ -6,7 +6,7 @@ auto-install:
check-system:
@$(COMMANDS_DIR)/check-system $(ARGS)
-build: check-system
+build:
@$(COMMANDS_DIR)/build
run: helpers-build
diff --git a/commands/helpers/build b/commands/helpers/build
index 99f3048..1904955 100755
--- a/commands/helpers/build
+++ b/commands/helpers/build
@@ -3,6 +3,8 @@
import common
from devbot import build
+from devbot import system
common.setup()
+system.check()
build.build()
diff --git a/commands/helpers/build-snapshot b/commands/helpers/build-snapshot
index 84b1150..1dbf2eb 100755
--- a/commands/helpers/build-snapshot
+++ b/commands/helpers/build-snapshot
@@ -43,7 +43,6 @@ runsugarscript=$rootdir/run-sugar.sh
cat > $runsugarscript << "EOF"
#!/bin/sh
-commands/check-system
commands/run
EOF
@@ -54,7 +53,6 @@ runshellscript=$rootdir/run-shell.sh
cat > $runshellscript << "EOF"
#!/bin/sh
-commands/check-system
commands/shell
EOF
diff --git a/commands/run b/commands/run
index 2bc3a31..c71fe66 100755
--- a/commands/run
+++ b/commands/run
@@ -5,6 +5,8 @@ helpersdir=$commandsdir/helpers
rootdir=`dirname "$commandsdir"`
display=`$helpersdir/find-free-display`
+$commandsdir/check-system
+
if [ -f $rootdir/prefs ]; then
source $rootdir/prefs
fi
diff --git a/devbot/system.py b/devbot/system.py
index 8e493cf..2a8d189 100644
--- a/devbot/system.py
+++ b/devbot/system.py
@@ -164,6 +164,8 @@ def remove_packages(package_manager, packages):
package_manager.remove_packages(to_remove)
def check(remove=False, update=False, test=False, interactive=True):
+ print "Checking the system"
+
package_manager = \
distro.get_package_manager(test=test, interactive=interactive)