Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-26 09:49:57 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-12-26 09:49:57 (GMT)
commitbc6035454c6138d0974173900e50e33793b2e5d0 (patch)
tree2fe621acb441656affd1a8df7421d030f79a9d36
parent1a476385ef6d2b8f74543b4457aec2ddecf6ee88 (diff)
Require only virtualenv rather than buildbot
-rw-r--r--Makefile.config1
-rw-r--r--commands/common.py1
-rw-r--r--config/deps/sugar-build.json5
-rw-r--r--config/packages/buildslave.json13
-rw-r--r--config/packages/deps.json11
-rw-r--r--devbot/config.py16
6 files changed, 21 insertions, 26 deletions
diff --git a/Makefile.config b/Makefile.config
index 5959c60..c8ceb2f 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -21,7 +21,6 @@ CONFIG_PACKAGES_DIR=config/packages
CONFIG_PACKAGES= \
$(CONFIG_PACKAGES_DIR)/basesystem.json \
- $(CONFIG_PACKAGES_DIR)/buildslave.json \
$(CONFIG_PACKAGES_DIR)/deps.json
CONFIG_MAIN=config/config.json
diff --git a/commands/common.py b/commands/common.py
index 61d9537..e9f5293 100644
--- a/commands/common.py
+++ b/commands/common.py
@@ -22,7 +22,6 @@ def setup():
if "SUGAR_BUILDBOT" in os.environ:
args["relocatable"] = True
- args["extra_packages_files"] = ["buildslave.json"]
config.setup(**args)
diff --git a/config/deps/sugar-build.json b/config/deps/sugar-build.json
index 753d437..bda4164 100644
--- a/config/deps/sugar-build.json
+++ b/config/deps/sugar-build.json
@@ -40,6 +40,11 @@
"name": "time"
},
{
+ "check": "virtualenv",
+ "checker": "binary",
+ "name": "virtualenv"
+ },
+ {
"check": "x11",
"checker": "pkgconfig",
"name": "x11"
diff --git a/config/packages/buildslave.json b/config/packages/buildslave.json
deleted file mode 100644
index 91bcecc..0000000
--- a/config/packages/buildslave.json
+++ /dev/null
@@ -1,13 +0,0 @@
-{
- "buildslave": {
- "debian": [
- "buildbot-slave"
- ],
- "fedora": [
- "buildbot"
- ],
- "ubuntu": [
- "buildbot-slave"
- ]
- }
-}
diff --git a/config/packages/deps.json b/config/packages/deps.json
index 072aa9c..1b1160c 100644
--- a/config/packages/deps.json
+++ b/config/packages/deps.json
@@ -791,6 +791,17 @@
"time"
]
},
+ "virtualenv": {
+ "debian": [
+ "python-virtualenv"
+ ],
+ "fedora": [
+ "python-virtualenv"
+ ],
+ "ubuntu": [
+ "python-virtualenv"
+ ]
+ },
"vte python": {
"debian": [
"python-vte"
diff --git a/devbot/config.py b/devbot/config.py
index 044c048..a66a196 100644
--- a/devbot/config.py
+++ b/devbot/config.py
@@ -26,7 +26,6 @@ build_state_dir = None
_source_dir = None
_build_dir = None
_prefs_path = None
-_extra_packages_files = []
class Module:
def __init__(self, info):
@@ -86,9 +85,6 @@ def setup(**kwargs):
global _build_dir
_build_dir = kwargs["build_dir"]
- global _extra_packages_files
- _extra_packages_files = kwargs.get("extra_packages_files", [])
-
relocatable = kwargs.get("relocatable", False)
_setup_state_dir(kwargs["state_dir"])
@@ -231,16 +227,14 @@ def _load_plugins():
f, filename, desc = imp.find_module(name, plugins.__path__)
imp.load_module(name, f, filename, desc)
-def _read_index(dir_name, extra=[]):
- files = extra[:]
-
+def _read_index(dir_name):
if config_dir is None:
- return files
+ return []
index_dir = os.path.join(config_dir, dir_name)
with open(os.path.join(index_dir, "index.json")) as f:
- files.extend(json.load(f))
- return [os.path.join(index_dir, json_file) for json_file in files]
+ return [os.path.join(index_dir, json_file) \
+ for json_file in json.load(f)]
def get_full_build():
config = None
@@ -252,7 +246,7 @@ def get_full_build():
def load_packages():
packages = {}
- for path in _read_index("packages", _extra_packages_files):
+ for path in _read_index("packages"):
packages.update(json.load(open(path)))
return packages