Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-25 18:01:03 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-12-25 18:01:03 (GMT)
commitc05e755ced4ce4d528ffc5b34ddb44892e2f938f (patch)
treef10ffb0418f45f5d25cae44119605952ceca6685
parent3022a9c90a374a9c6ba402b6aede0a503bf6315e (diff)
Add --full to the build command
-rw-r--r--Makefile.commands2
-rwxr-xr-xcommands/build3
-rw-r--r--devbot/build.py4
3 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.commands b/Makefile.commands
index be82830..17908dd 100644
--- a/Makefile.commands
+++ b/Makefile.commands
@@ -10,7 +10,7 @@ pull:
@$(COMMANDS_DIR)/pull
build:
- @$(COMMANDS_DIR)/build
+ @$(COMMANDS_DIR)/build $(ARGS)
run:
@$(COMMANDS_DIR)/run
diff --git a/commands/build b/commands/build
index d86fecd..714e783 100755
--- a/commands/build
+++ b/commands/build
@@ -10,6 +10,7 @@ from devbot import build
parser = argparse.ArgumentParser()
parser.add_argument("module", nargs="?", help="name of the module to build")
+parser.add_argument("--full", action="store_true", help="force a full build")
args = parser.parse_args()
common.setup()
@@ -20,7 +21,7 @@ if not system.check(skip_if_unchanged=True):
if args.module:
success = build.build_one(args.module)
else:
- success = build.build()
+ success = build.build(full=args.full)
if not success:
sys.exit(1)
diff --git a/devbot/build.py b/devbot/build.py
index 06d6874..1e33c70 100644
--- a/devbot/build.py
+++ b/devbot/build.py
@@ -43,12 +43,12 @@ def pull():
return True
-def build():
+def build(full=False):
environ.setup()
_ccache_reset()
- if state.full_build_is_required():
+ if full or state.full_build_is_required():
clean()
state.full_build_touch()