Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-07-04 11:03:19 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-07-04 11:03:19 (GMT)
commitef6aba68ad672d44811033eb2568db0c30ed9527 (patch)
tree853708ac250268ea430fa5c2847ce1f3933c8e61
parentbb0a4da2fe52275d18a15ffdcb14acee6807e602 (diff)
Allow to run another instance inside sugar
-rw-r--r--Makefile8
-rw-r--r--scripts/xinitrc6
2 files changed, 13 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8faa5bb..81175e8 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,12 @@ SCRIPTS = $(CURDIR)/scripts
JHBUILD = $(CURDIR)/install/bin/jhbuild -f $(SCRIPTS)/jhbuildrc
LOG = $(SCRIPTS)/log-command
+ifdef SUGAR_SESSION
+XINITDISPLAY = :100
+else
+XINITDISPLAY = :99
+endif
+
# The buildbot shell does not handle script properly. It's unnecessary
# anyway because we can't use interactive scripts there.
ifdef SUGAR_BUILDBOT
@@ -43,7 +49,7 @@ build-%:
$(TYPESCRIPT) "$(JHBUILD) buildone $*" $(LOGFILE)
run: scripts/list-outputs
- xinit $(SCRIPTS)/xinitrc -- :99
+ xinit $(SCRIPTS)/xinitrc -- $(XINITDISPLAY)
test:
$(LOG) "$(SCRIPTS)/run-dogtail-tests" $(LOGFILE)
diff --git a/scripts/xinitrc b/scripts/xinitrc
index 466d4f0..1dca413 100644
--- a/scripts/xinitrc
+++ b/scripts/xinitrc
@@ -23,6 +23,12 @@ do
fi
done
+if [ -z $SUGAR_SESSION ]; then
+ export SUGAR_SESSION=yes
+else
+ export SUGAR_PROFILE=development
+fi
+
JHBUILD="$ROOT_DIR/install/bin/jhbuild -f $ROOT_DIR/scripts/jhbuildrc"
RUN_COMMAND="dbus-launch --exit-with-session sugar"