Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.buildbot
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-24 17:31:28 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-24 17:31:28 (GMT)
commite485db532f3ac5519ec4bd975cc969794c5bce7f (patch)
tree978666ff3fba8219f70b9fd347767e310a894b62 /Makefile.buildbot
parent50989f1fc95c9dfa685ddfd6c4dd7dd581e1a3f7 (diff)
Make sure snapshot has a sugar-build root
Diffstat (limited to 'Makefile.buildbot')
-rw-r--r--Makefile.buildbot16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.buildbot b/Makefile.buildbot
index a78ded9..0bc507a 100644
--- a/Makefile.buildbot
+++ b/Makefile.buildbot
@@ -13,12 +13,14 @@ upload-snapshot:
@TMP_DIR=`mktemp -td sugar-build-snapshot-XXXX` && \
SNAPSHOT_FILENAME=sugar-build-`date +%Y%m%d-%H%M%S.tar.xv` && \
echo "Creating $$SNAPSHOT_FILENAME" && \
- tar cJ --exclude=source \
- --exclude=build \
- --exclude=logs \
- --exclude=.git* \
- -f $$TMP_DIR/$$SNAPSHOT_FILENAME . && \
+ ln -s `pwd` $$TMP_DIR/sugar-build && \
+ cd $$TMP_DIR && \
+ tar chJ --exclude=source \
+ --exclude=build \
+ --exclude=logs \
+ --exclude=.git* \
+ -f $$TMP_DIR/$$SNAPSHOT_FILENAME sugar-build && \
echo "Uploading" && \
- scp $$TMP_DIR/$$SNAPSHOT_FILENAME $(SNAPSHOT_DEST) && \
- rm -f $$TMP_DIR/$$SNAPSHOT_FILENAME && \
+ scp $$SNAPSHOT_FILENAME $(SNAPSHOT_DEST) && \
+ rm -f $$SNAPSHOT_FILENAME && \
ssh $(SNAPSHOT_DEST_HOST) $(SNAPSHOT_DEST_DIR)/upload-completed